TELECHARGEMENTS

Logiciel de Télémaintenance: FASTware_telemaintenance.exe (262 kO)


NOTE: Les téléchargements suivants sont réservés pour les clients avec un contrat de support actif (nécessite un mot de passe).

Produits FASTware version 7.2
Programmes d'installation: Release notes v. 7.1.3 (seulement en anglais)
Release notes v. 7.0.8 (seulement en anglais)

* Note 1: Les programmes d'installation de FASTware permettent aussi la mise à jour des systèmes ayant déjà une version de FASTware installée (mise à jour de v. 6.x.x/7.xx à v. 7.2.11). Dans le cas d'une mise à jour de FASTware, la partie FwAxes n'est pas modifiée (si nécessaire, il faut donc la mettre à jour en utilisant le programme "FwAxes Upgrade").
* Note 2: Les programmes d'installation de FASTware ne contiennent pas la dernière mise à jour de la partie FwAxes mais la vesion 161 (il faut donc aussi la mettre à jour en utilisant le programme "FwAxes Upgrade").
* Note 3: Les version 6.4, 7.0, 7.1 et 7.2 de FASTware sont compatibles, une application développée avec FASTware version 7.2 peut être éxécutée sur une cible avec FASTware version 6.4, 7.0 ou 7.1, et inversement (application 6.4 sur une cible 7.0/7.1/7.2).
* Note 4: Avant d'installer FASTware sur windows 7 64-bit, celui ci doit être mis à jour (Téléchargement) (idem pour windows Vista (Téléchargement)). Pour Windows 7, vous pouvez être confronté à ce problème (suivre ce lien).


Produits FASTware version 6.4
Note: avec cette version, les applications FASTware (cible) ne fonctionnent pas sur windows 64-bit.
Programmes d'installation: Release notes v. 6.4.38 (seulement en anglais)

* Note 1: Les programmes d'installation de FASTware permettent aussi la mise à jour des systèmes ayant déjà une version de FASTware installée (mise à jour de v 6.x.x.x à v 6.4.38.x). Dans le cas d'une mise à jour de FASTware, la partie FwAxes n'est pas modifiée (si nécessaire, il faut donc la mettre à jour en utilisant le programme "FwAxes Upgrade").
* Note 2: Les programmes d'installation de FASTware ne contiennent pas la dernière mise à jour de FwAxes mais la version 161 (il faut donc aussi la mettre à jour en utilisant le programme "FwAxes Upgrade").

**Note 1: Après la mise à jour d'une version plus ancienne que x.x.x.149: lors de l'exécution d'une application, les fichiers de configuration sont mis à jour dans un nouveau format. La base d'axes est convertie de xxx.axs à xxx.fwaxs, et les fichiers de cycle sont convertis de .cyc à .fwcyc.
**Note 2: Pour utiliser cette mise à jour FwAxes (x.x.x.163 et plus) vous devez avoir la version de développement 6.4.16 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).
**Note 3: Pour utiliser toutes les fonctionnalités de la mise à jour FwAxes de version x.x.x.174 et plus, vous devez avoir la version de développement 6.4.35 ou plus.
**Note 4: Pour utiliser la mise à jour FwAxes version 169 et plus, vous devez avoir la version de développement 6.4.19 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).


Produits FASTware version 6.2
Note: avec cette version, les applications FASTware (cible) ne fonctionnent pas sur windows 64-bit.
Programmes d'installation: * Note 1: Les programmes d'installation de FASTware permettent aussi la mise à jour des systèmes ayant déjà une version de FASTware installée (mise à jour de v 6.x.x.x à v 6.2.3.x). Dans le cas d'une mise à jour de FASTware, la partie FwAxes n'est pas modifiée (si nécessaire, il faut donc la mettre à jour en utilisant le programme "FASTware Upgrade").
* Note 2: Les programmes d'installation de FASTware ne contiennent pas la dernière mise à jour de la partie FwAxes mais la version 148 (si nécessaire, il faut donc aussi la mettre à jour en utilisant le programme "FASTware Upgrade").

**Note 1: Après la mise à jour d'une version plus ancienne que x.x.x.149: lors de l'exécution d'une application, les fichiers de configuration sont mis à jour dans un nouveau format. La base d'axes est convertie de xxx.axs à xxx.fwaxs, et les fichiers de cycle sont convertis de .cyc à .fwcyc.
**Note 2: Pour utiliser cette mise à jour FwAxes (x.x.x.163 et plus) vous devez avoir la version de développement 6.2.4 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).


Produits FASTware version 6.0
Programmes d'installation:
Note: avec cette version, les applications FASTware (cible) ne fonctionnent par sur windows 64-bit ni sur un système multi-processeurs, et ne s'exécutent que sur windows 2000 et XP.
**Note 1: Après la mise à jour d'une version plus ancienne que x.x.x.149: lors de l'exécution d'une application, les fichiers de configuration sont mis à jour dans un nouveau format. La base d'axes est convertie de xxx.axs à xxx.fwaxs, et les fichiers de cycle sont convertis de .cyc à .fwcyc.
* Note 2: Les programmes d'installation de FASTware ne contiennent pas la dernière mise à jour de la partie FwAxes mais la version 98 (si nécessaire, il faut donc aussi la mettre à jour en utilisant le programme "FASTware Upgrade").
**Note 3: La version 161 de la mise à jour FwAxes est la dernière version supportée par FASTvware version 6.0.


Produits FASTware version 5.4

Cette version est pour les produits FASTbus-1.
Note: avec cette version, les applications FASTware (cible) ne fonctionnent par sur windows 64-bit ni sur un système multi-processeurs, et ne s'exécutent que sur windows 2000 et XP.
Programmes d'installation: * Note 1: Les programmes d'installation de FASTware ne contiennent pas la dernière mise à jour de la partie FwAxes mais la version 83 (si nécessaire, il faut donc aussi la mettre à jour en utilisant le programme "FASTware Upgrade").
**Note 2 concernant la mise à jour d'une version FwAxes plus ancienne que 149: lors de l'exécution d'une application, les fichiers de configuration sont mis à jour dans un nouveau format. La base d'axes est convertie de xxx.axs à xxx.fwaxs, et les fichiers de cycle sont convertis de .cyc à .fwcyc.
**Note 3: Pour utiliser cette mise à jour FwAxes (v.163 et plus) vous devez avoir la version de développement 5.4.3 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).
**Note 4: Pour utiliser une à jour FwAxes de version 168 et plus, vous devez avoir la version de développement 5.4.4 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).
**Note 5: Pour utiliser la mise à jour FwAxes version 179 et plus, vous devez avoir la version de développement 5.4.5 ou plus, pour pouvoir compiler une tâche process (avec FwSysDev).

Historique des produits FASTware version 5.4

Exemples pour le développement d'application

Exemple (pas à pas) pour commencer le développement d'application avec FASTware.

Cybelec
FASTware, le système de commande...
                                            ...à votre mesure

Swiss made
Swiss Made