DOWNLOAD

Remote maintenance software: FASTware_telemaintenance.exe (262 kB)


NOTE: Download of the following programs is reserved for customers with active support contract (password needed).

FASTware version 7.2, Product download
Install programs: Release notes v. 7.1.3
Release notes v. 7.0.8

* Note 1: The FASTware install programs may also be used to update systems with FASTware already installed on them (update from v 6.x.x/7.x.x to v 7.2.11). When updating FASTware, the FwAxes part is not changed (to update it, you must use the FwAxesUpgrade program).
* Note 2: The FASTware install programs does not contain the latest release of FwAxes but version 161 (use the FwAxes Upgrade program).
* Note 3: FASTware version 7.2 is compatible with version 6.4, 7.0 and 7.1. An application using FASTware version 7.2 may be executed on a target with FASTware version 6.4, 7.0 ou 7.1, and also an application with version 6.4 on a target with version 7.0, 7.1 or 7.2.
* Note 4: Before installing FASTware on windows 7 64-bit, it must be up to date (Download) (idem for windows Vista (Download)). On windows 7, you may encounter this bug (follow this link).


FASTware version 6.4, Product download
Note: with this version, FASTware applications (target) cannot run on 64-bit Windows.
Install programs: Release notes v. 6.4.38

* Note 1: The FASTware install programs may also be used to update systems with FASTware already installed on them (update from v 6.x.x.x to v 6.4.38.x). When updating FASTware, the FwAxes part is not changed (to update it, you must use the Upgrade program).
* Note 2: The FASTware install programs does not contain the latest release of the FwAxes part but version 161 (if needed, use the Upgrade program).

**Note 1: If upgrading a version less than x.x.x.149: when running application, the configuration files are updated to a new format. The axes data base is converted from xxx.axs to xxx.fwaxs, and the cycle files are converted from .cyc to .fwcyc.
**Note 2: To use this FwAxes upgrade (x.x.x.163 and more) you must have the development version 6.4.16 or more to be able to compile the process task (with FwSysDev).
**Note 3: To use all the functionalities of FwAxes upgrade version x.x.x.174 and more, you must have the development version 6.4.35 or more.
**Note 4: To use this FwAxes upgrade v. 169 and more, you must have the development version 6.4.19 or more to be able to compile the process task (with FwSysDev).


FASTware version 6.2, Product download

Note: with this version, FASTware applications (target) cannot run on 64-bit Windows.
Install programs: * Note 1: The FASTware install programs may also be used to update systems with FASTware already installed on them (update from v 6.x.x to v 6.2.6). When updating FASTware, the FwAxes part is not changed (to update it, you must use the Upgrade program).
* Note 2: The FASTware install programs does not contain the latest release of FwAxes but version 148 (if needed, use the Upgrade program).

**Note 1: If upgrading a version with FwAxes less than v.149: when running application, the configuration files are updated to a new format. The axes data base is converted from xxx.axs to xxx.fwaxs, and the cycle files are converted from .cyc to .fwcyc.
**Note 2: To use this FwAxes upgrade (v.163 and more) you must have the development version 6.2.4 or more to be able to compile the process task (with FwSysDev).


FASTware version 6.0, Product download
Note: with this version, FASTware applications (target) cannot run on 64-bit Windows nor on multi-processor system, and only run on windows 2000 and XP.
Install program: **Note 1: If upgrading a version of FwAxes less v.149: when running application, the configuration files are updated to a new format. The axes data base is converted from xxx.axs to xxx.fwaxs, and the cycle files are converted from .cyc to .fwcyc.
* Note 2: The FASTware install programs does not contain the latest release of FwAxes but version 98 (if needed, use the Upgrade program).
**Note 3: The FwAxes upgrade version x.x.x.161 is the lastest version supported by the FASTware version 6.0.


FASTware version 5.4, Product download
This version is for FASTbus-1 products.
With this version, FASTware applications (target) cannot run on 64-bit Windows nor on multi-processor system, and only run on windows 2000 and XP.
Install programs:
**Note 1: If upgrading a version less than x.x.x.149: when running application, the configuration files are updated to a new format. The axes data base is converted from xxx.axs to xxx.fwaxs, and the cycle files are converted from .cyc to .fwcyc.
**Note 2: To use this FwAxes upgrade (x.x.x.163 and more) you must have the development version 5.4.3 or more to be able to compile the process task (with FwSysDev).
**Note 3: To use this FwAxes upgrade (x.x.x.168 and more) you must have the development version 5.4.4 or more to be able to compile the process task (with FwSysDev).
**Note 4: To use this FwAxes upgrade v. 169 and more, you must have the development version 5.4.5 or more to be able to compile the process task (with FwSysDev).
* Note 5: The FASTware install programs does not contain the latest release of FwAxes but version 83 (if needed, use the Upgrade program).

FASTware Product History of version 5.4

Tutorials for development of applications using FASTware

Examples and tutorials (step by step) to start development of an application using FASTware.

Cybelec
FASTware, the automation control system...
                                            ...tailored for you

Swiss made
Swiss Made